Windows 7 won't update.....

Discussion in 'Hardware - PCs, Consoles, Gadgets' started by The_Big_Floater, Apr 11, 2011.

Welcome to the Army Rumour Service, ARRSE

The UK's largest and busiest UNofficial military website.

The heart of the site is the forum area, including:

  1. Guys,

    my new Desktop, will not auto update, I have tried to adjust the power settings and the sleep function, plus I have tried to manually update the OS, and the machine will not update or even give up. I still get the blue screen and the attempt to install and configure every time I turn it on and off, as i am now awaiting 64 updates to configure then fail I am getting fing angry.

    Anyone out there with a solution as the windows home page is fing useless.....
     
  2. When manually trying to update, does the error message come up? Something along the lines of "0x000081" or the like?

    Firstly, though, check the Windows Update Service is running. Click the Start orb, and in the text box that pops up directly above it, type services.msc. Scroll down the window which appears, and have a look at Windows Update - is it started and running?
     
  3. Try disabling the windows firewall and re-running the updates. Might also be worth while turning the UAC off while trying to install them.
    This is in Control Panel\User Accounts and Family Safety\User Accounts\Change User Access Control Settings.
    Hope that helps,

    edit: Forgot to add, make sure you turn the firewall back on!
     
  4. thanks guys unfortunatley no joy
     
  5. I suspect that the update files you've downloaded are corrupted and need to be re-downloaded. You can do this simply by following the advice below. Firstly though, if you don't have Service Pack 1 yet, download this and try the installation as it rolls up most of the security patches for you. If you're still getting problems with SP1 installed, or you can't install SP1 then there's a few ways to sort this out. Firstly you have to know exactly what is going wrong. This is best done via the logs

    Try the update again now, then when it fails, immediately open the Windows Update Log which is located in your default system drive (usually the C drive) under the Windows directory. Compare the time in the log to any error messages. You can ALSO look at the Event Log in Control Panel (under administrative tools and Event Viewer). Look for any error entries relating to the update.

    You can try the following as well to refresh the download patches

    1. Close Internet Explorer
    2. Delete the WebSetup folder at C:\windows\SoftwareDistribution
    3. Visit Windows Update, Click "Express"
    4. Check that the WebSetup folder has been restored
    5. Close Internet Explorer
    6. Stop the Automatic Updates Service (Do NOT disable it!)
    7. Browse to C:\WINDOWS\ServicePackFiles\i386 (Different on 64 bit Editions)
    8. Locate wuaueng.dll within the i386 folder, copy it
    9. Paste wuaueng.dll to c:\windows\system32\dllcache (Overwrite)
    10. Delete wuaueng.dll within C:\Windows\System32 (Windows will restore it almost instantly, no problem --)
    11. Start the Automatic Updates Service [Again]
    12. Visit the Windows Update site
    13. Download the "Newer Version"
    14. Test it...