VM super hub & d-link router but 'no internet access'

Discussion in 'Hardware - PCs, Consoles, Gadgets' started by Your_Mums_Pal, Jul 13, 2012.

Welcome to the Army Rumour Service, ARRSE

The UK's largest and busiest UNofficial military website.

The heart of the site is the forum area, including:

  1. Hi folks,

    So I've been given Virgin's new superhub modem/router combo. It's a shit piece of kit, it has hardly any wi-fi signal, unless you're sitting next to it or plugging into it with an ethernet cable. So after enduring it for a couple of days I decided to plug in my Dlink router, which helped signal/speed wise.

    I have a PS3 which connects no problem and uses the internet through it.

    An old XP laptop which connects and also gets decent internet.

    My Windows 7 PC, however, will connect to the wireless network but will tell me it has 'No Internet Access' and give me a little yellow warning over the connection icon in the tray.

    It is a ******* nightmare.

    I've tried everything under the sun, from changing DNS gateways to manually entering IP addresses. I've re-installed the wireless adaptor ten times, tried to change settings on both the d-link router and superhub router but to no avail. It has a strong signal but and sits connected to the network no problem but just tells me 'No Internet Access' and won't get online whatsoever.

    Today, deciding to go back to the default Virgin set-up, ditching MY router, the whole ******* network is slow as hell. I did a full system restore (pinhole reset) on the superhub and just connected to the network they supplied but now the internet is crawling along.

    Basically, does anybody know why my Win7 PC has 'no internet access' despite being plugged into the network? It's frustrating as all hell, particularly as the PS3 and laptop have no problems.
     
  2. Antivirus blocking it? 1. try rebooting to safe mode with networking and see what happens. 2. If it works in safe mode+net, reboot normally, disable all non-Microsoft services (msconfig at a command prompt) and re-enable them one at a time until you get which one is blocking it.
    Assuming that 1. works!
     
  3. Grumblegrunt

    Grumblegrunt LE Book Reviewer

    I get that on one of mine, all the other win 7 machines connect for the most part but one sits with the yellow triangle for a few mins even though windows update will work until I start chrome which seem sot get it going. a few of the other win 7 machines also do it every now and again so it seems to be a win7 issue. from what I've been reading changing the adapter mtu (whatever that is) in the registry would sort it out.

    others suggest checking you arent clashing with other networks on the same channel, if you pick up a lot of networks then download inssider and see where the free bandwidth is.
     
  4. I have the same problem with my I phone and I pad if I use either donwn stairs it pants
     
  5. Well I reset the whole thing back to default using the pin reset just to use the normal Virgin network and the connection is now gone. According to the service on virgins site everything is fine but my connection won't work on anything now. Using phone to read arrse. Temper is wearing thin. I'll try the safe mode connection when I get it working. The only solution available on google search that seems to work for others is a full system restore!
     
  6. Power off the Virgin router for 45 minutes. That's probably the next thing they'll tell you to do anyway.
     
  7. SD, do you know if the superhub is notorious for being shit?
     
  8. Virgin is notorious for being shit in all aspects, and not just the hub.

    BT Infinity FTW. I'm getting 80 megabit, and never had any downtime. I spoke nicely to them, and they let me have the settings so I could use my own Cisco 887 VDSL router and Aironet WiFi.

    have you had a look at the SuperHub's embedded web interface to see what it says ie, any error messages? Type 192.168.0.1 into you browser address bar. USername is superuser, password is 1234.
     
  9. I tried that, mate, but with no joy. It doesn't necessarily tell me anything. The superhub just has a terrible connection, as mentioned before, with the hub in modem mode and the dlink router connected, the signal is excellent but my PC just won't access the internet despite being connected to the network.

    changed the security type to suit me and have chosen channel 6 as it's default and it's working fine wirelessly with the lappy now. I don't know what the hell I'm going to do to tweak the PC's connectivity.
     
  10. That was what I had done initially - as I said, there was a perfectly good connection doing that. The Windows 7 PC simply did not like it. Another website I browsed suggested that the superhub, in modem mode, just wasn't set up to talk to my router properly.
     
  11. I know you've tried this, but uninstall the network card from Windows control panel>device manager, uninstall the software for the device if asked, and then immediately restart the computer. Windows should find it again by itself.

    Vista had a similar issue with certain network chipsets, and the driver model and TCPIP stack on Vista and 7 is broadly the same. My early Vista machine had this issue, and I had to do the above quite a lot.
     
  12. Tried that, had to re-install the device driver to make it work again. It's not a card, it's an external adapter, a wee belkin USB thing I picked up a couple of months ago on an away trip with work. It works perfectly well in the laptop and it appears to work well on the PC but, as I say, the PC picks up the network but can't get onto the internet. I definitely think it's just a windows 7 issue, as GG pointed out earlier.
     
    • Like Like x 1
  13. Aye, but still...it works with the laptop. It's still connecting to the network from the PC, just not allowing internet access. Although now that I'm just running from the superhub, well, it's picking up hardly any signal at all.