Search function

#1
It's been improved and broken :(
 
#2
What's up with it?

It hasn't been improved, but it slows the site down a lot at a time when we're pushing the limits, so we've tried to stop bots triggering it, tried to encourage people to use Google's servers and not us, and also it should stop malicious use.

Anyway, what doesn't work?
 
#4
I'm still not convinced that bots can slow our site by filling out search forms, but heh, it might help.
 
#5
Ahhhhhhhhhh

I wondered why there was a new code thingy. Getting to grips with it now, it's not broken :)
 
#7
No idea - I haven't seen any mention of such a thing, just the site search that I've used. There are loads of google experiments and widgets around though so I may have missed it. Do you have a link?
 
#8
I might have finger trouble here, but the enter code box won't let me enter the code?
 
#10
Good CO said:
No idea - I haven't seen any mention of such a thing, just the site search that I've used. There are loads of google experiments and widgets around though so I may have missed it. Do you have a link?
you seem to have found one! Brilliant - just what was required. It doesn't seem to direct you back into the normal site but I suspect that's a detail you'll soon sort out.
Good stuff.
 
#11
hackle said:
PartTimePongo said:
I might have finger trouble here, but the enter code box won't let me enter the code?
same here

Sorry, but your search was not completed because of an error, perhaps with the security code. Please try again.
Yup, same here. School boy error of getting stuff working in Firefox and forgetting to check it in IE. I'll get it sorted. Thanks for the spot. Does stop people using it though!
 
#13
ERR No it isnt, I keep getting an error message

Sorry, but your search was not completed because of an error, perhaps with the security code. Please try again.
 
#14
This SHOULD only happen if

1) You type in the wrong code :)

2) You leave the page for longer than a minute with the same code before submitting

3) You don't enter anything in the search box.

I've just tested it again and it's going fine. I can't see any reason why the function (not the appearance) should be browser dependent either, but just to check I did a search in IE and FF.

Can you try it a few times and tell me if there's anything consistent about the problem or whether you always get problems? Any more detail you can give would be good to - what exactly you were searching for and so on.
 
#15
Won't work for me - entered the code (tried case sensitive and not case sensitive) and completed the search in good time. The error message comes back each time. Back to work then, I suppose.
 
#16
I don't understand why for me and not for you.

Just to check - excuse me if this is insulting, to use the non-google 'advanced search' bit you're filling in your search query where it says "search for keywords", NOT in the google search box? The two search forms are separate.
 
#17
Other points which may be causing trouble and if so let me know and I'll add info:

It is case sensitive but all letters in it are upper case, so just enter what you see.

If in doubt about:
O and 0, it's O - 0 is obviously narrower when you see it.
I or 1, then it's I. 1 has a tip.
B or 8 - it's B. 8 is a very obvious shrivelled thing.

If that helps or was the problem let me know and I'll find a way to clarify.

Also I've just noticed that your search words aren't preserved when the form reloads which I'll fix.
 
#18
I'm not even a little bit insulted.

Tried again: double check that search term in correct box, case sensitivity noted and applied, search button pressed. Still not working, same error message about code. Tried refreshing code to attempt with a different one but it remains the same, through several applications of the refresh function. Maybe this is work's way of telling me to get back to doing it and not swanning around in here.
 
#19
Colonel,

I've just tried it and failed - wrong code.

But I am inside a firewall and I seem to have "Done, but with errors on page." permanently at the bottom left of my IE6 screen.

Litotes
 
Thread starter Similar threads Forum Replies Date
jarrod248 ARRSE: Site Issues 17
tattybadger The NAAFI Bar 6
Provost ARRSE: Site Issues 5

Similar threads

New Posts

Latest Threads