Problems with an external harddrive

Discussion in 'Hardware - PCs, Consoles, Gadgets' started by gorilla, Aug 11, 2011.

Welcome to the Army Rumour Service, ARRSE

The UK's largest and busiest UNofficial military website.

The heart of the site is the forum area, including:

  1. Hi,
    I bought a Western Digital 2 TB HD, it worked fine for 6 weeks, then for no reason it stopped registering on my laptop. When i disconnected it it came up with the message "drive needs formatting". Anyone know whats gone on, can it be repaired or if not, can the data be retrieved?

    Many Thanks
  2. Not taken a bump has it? they can be quite temperamental, especially if the larger 3.5" disks rather than the smaller 2.5" ones. Give it a try on another computer if you can, see if it does the same on that. Additionally try it in a different USB port, had that before which was odd
  3. Had same problem recently with a 2.5 inch. I did what Acidcrash's advice says - it worked in another computer so i dumped the files on it, reformatted then put them back on. It's still dodgy so I bought a new one in the end.
  4. Grumblegrunt

    Grumblegrunt LE Book Reviewer

    is it one of their otherwise pretty good book drives?

    its probably due to windows trying to access it while its asleep and claiming a fail, the fault is usually more windows than the drive but sometimes its the card in the housing. it can also be the usb port on the pc is asleep and doesnt turn back on quick enough.

    I have a media drive which is a hardware player that sits in the network attached to the telly so it can play from its internal drive or the NAS ones. often when I connect via usb to move files it gives the same message. I usually take the drive out and put it in something else. for some reason just being accessed via another interface sorts it out and it runs fine again after that.

    worst case I would draw the files off and try a different format but the files arent lost just not recognised. partition find and mount is pretty good and file scavenger is exellent

    what happens when you plug the usb cable in and then power up the drive?
  5. when i plug the usb cable in and power up the drive on my pc as opposed to my laptop, i get a symbol on my toolbar saying "device is ready to use other than that nothing happens, it doesn't even register on "my computer".
  6. Do you have anything else plugged in/connected that could be using the drive letter that your HD used last time?

    Sounds odd but I had the same problem with a camera that just had to be the G: drive and wouldn't work if that was being used by a network mapping.
  7. It could be the USB cable. I have a WD drive which is very temperamental about which cable is used to connect it - it worked fine with the original cable for a while.
  8. Grumblegrunt

    Grumblegrunt LE Book Reviewer

    on the my computer icon or start menu my computer if you right click and select manage you get the computer management console, select disk management and it will bring up everything recognised by the machine by disk and what it sees on that disk.

    right clicking on the partition you can change the drive letter, explore it etc or format it. if there is a clash with the path then change it to something like Q or Z if that doesnt see the drive as formatted then you can quick format it and then recover anything mislaid on the drive.
  9. Mr Happy

    Mr Happy LE Moderator

    as other posters have said, it happens with external drives, I've had all these issues and more, the 'wrong' cable, wrong hole ;-) and pulling it out and trying again have all fixed it. I've also (for the sake of completeness) had issues with the format, e.g. FAT16 vs FAT32 vs NTFS and so on.

    That's why I back up my back up...