printer won't (re)install!

Discussion in 'Hardware - PCs, Consoles, Gadgets' started by Recce19, Feb 21, 2012.

Welcome to the Army Rumour Service, ARRSE

The UK's largest and busiest UNofficial military website.

The heart of the site is the forum area, including:

  1. I have a Canon MG5150 printer and all was well until my system crashed! Now it won'T load the drivers and refuses a reinstall.

    When it is turned on, XP Pro recognises it is there as 'Found New hardware' and even correctly names it. Then the fail happens! sometimes it asks for a file called 'prn2kxp.cab' but can't find it! I have treid to cancel and then install from the disk that came with the printer and run into another problem!...

    I get the error telling my the my spool service is not running. I turn it on and try again, but the spool service immediately turns back off!

    This is doing my head in and would like to know a work around, that doesn't involve a re-install of windows!

    Any help from you techy gods????
     
  2. Have you tried a system restore to before the crash, that should sort it out.
     
  3. Yep and it won't restore to any previous snap shots! I think my registry is a bit fucked and the restore points also mullered! :evil:
     
  4. Have you tried restoring from Safe Mode that sometimes works.
     

  5. TBH I can't remember! :oops:....will give it another shot though - thanks!
     
  6. If not try a repair from your System discs
     
    • Like Like x 1
  7. Done that, but it keeps reverting to off almost immediately and the install fails!
     
  8. What 3rdStafford said, well that's certainly your 1st port of call.
     
  9. If you look at the dependencies of the Spooler service it will probably show RPC service as one that is needed. Is the RPC service running 1st?
     
  10. PA, that (RPC) is showing as started and running normally. Below is a screenshot of what happens when I try installing the drivers!

    Spooler failure.jpg
    As you can see, the Spooler Service is set to automatic, but it doesn't matter how many times I start it, it will turn itself off seconds later!
     
  11. You could go into the registry, and see if there is a service attached to your printer, then delete it from the registry? Though I'm not gonna even try to talk you through that on the net as there are too many variables. Though if you open regedit from the cmd line you will see all your services under HKLM\System\currentcontrolset\services. Is there anything under there that has anything to do with your printer?
     
  12. And don't forget to throw a six to start.

    I know this isn't helpful but I had the same problem with an HP Officejet 7210 all in one printer. It were a right basted I can tell thee. In the end I used Ccleaner to remove every HP file related to the poxy printer and then reinstalled the whole software pack.
     
  13. I was running a Dell laptop and an epson 3-in-one printer. I then bought an Acer laptop and the printer wouldn't work on it. After much cajoling ,pleading and swearing that would make an ARRSER blush, it transpired that the printer was only compatible with XP. The Acer is Windows7. Upgrade software is £30. TESCO have a Wi-Fi 3-in-one for £50. New printer coming soon. Old one to 2nd hand shop.
    Perhaps one to remember when upgrading.
     
  14. Are you looking for a garage door professional in Burlington? burlington garage doors Repair installs, repairs and services garage doors in Burlington. Our quality service is done by highly trained experts providing you with the best garage door repair and sales experience possible. We are committed to service and quality.