My Laptop won't switch on my Samsung LTE 4G Dongle

BuggerAll

LE
Kit Reviewer
Book Reviewer
I bought a Samsung LTE 4G dongle to take to Kenya. I plugged it in but it wouldn't connect to my network. I un-installed with a view to reinstalling but it wouldn't reinstall.

I installed it on SWMBO's Laptop and its fine. I copied the drivers across to my Laptop. I can find it in control panel/device manager and its confirmed as everything working properly it just won't start.

Although I can see it in Device manager I can't find it by searching or by looking at my files/devices etc. Its not showing in my devices in the 'notification' panel.

It dings when you take it in or out.
 
have you tried turning it off and back on again
 
Try a different port
What colour is the thick bit of both the USB PC and the dongle connector
White and yellow or both white? Or blue ?
 

BuggerAll

LE
Kit Reviewer
Book Reviewer
Tried different ports. Tried uninstalling and reinstalling although I had to copy it from another Laptop as it wouldn't recognise the Dongle on mine.
 
Is it a USB port next to the fan? I have had a nightmare with laptops and USB ports on the left side where the fan is
 

jinxy

LE
Have you got any other 3rd party wifi applications running. Toshiba and a few others use there own wifi managers. If so turn them off and just use windows. Also what did you copy? the folder in Programs folder will not install the drivers, You need the installer, download the latest from your dongle supplier.
 

bcsack

Old-Salt
go to device manager highlight the dongle - rt mouse & select uninstall. When it finishes go to Action (next to file) & select "scan for hardware changes". It'll reinstall & work.
 
Plug the dongle into another USB port and re-install the drivers. USB can be a bit funny at times.
Very true. It's not a USB 3 port is it? Although USB 3 is supposedly backward compatible with USB 2 devices, they sometimes don't work. I've got a few USB 2.0 drives that wont work in a 3.0 port.
 

Latest Threads

Top