Linksys WRT54G Router cable issue

Discussion in 'Gaming and Software' started by SparkySteve, Sep 2, 2008.

Welcome to the Army Rumour Service, ARRSE

The UK's largest and busiest UNofficial military website.

The heart of the site is the forum area, including:

  1. Right, I'm at the end of my (admittedly limited) skillset with this issue and need some help.

    I've got a NTL (now Virgin) cable modem which is plugged with CAT5 into the uplink port of a Linksys WRT54G router, and i then have two desktops and a laptop connected via CAT5 and a couple of other laptops running on the wireless.

    The problem i have is that it will take the Vista desktop an absolute age to connect to the internet proper, with numerous IP and adapter resets, and then it will drop connection after a small period of inactivity resulting in starting the process again. Worryingly, the wireless USB adapter i can plug into the Vista desktop seems to work better.
    The other computers don't have this problem and i solved it on an XP Laptop by disabling a couple of the internet protocols on the adapter page.

    I've tested the CAT5 connection to the desktop (Short of swapping it as it is cabled through the house) and coupled with it working intermittently i don't think the cable is at fault.
    I've updated the WRT54G's firmware to the latest manufacturer's version and am now tempted to try an open source firmware but am reluctant to brick the damn thing.

    I'm hoping that this is a simple "Turn QoS packets off on the adapter" issue that I've overlooked, is anyone able to assist on this one please?

    Many thanks,
    SparkySteve
     
  2. Do you know if it's the local connection (LAN/ethernet) that's dropping or the bit from the router to the internet? i.e. is it the PC's connection to the router itself or an ISP issue?

    Can you stay connected from your PC to the local address of the router? normally a browser session to http://192.168.1.1 - if so then it's not the problem and the TCP/IP settings of your PC are ok. However you might want to try switching between a DHCP address and a static one to see if the connection is quicker. Then try disabling IP version 6 in your TCP/IP settings incase it's incompatible with your router.

    Can you see if the modem is staying connected (check the logs) and whether it's the ISP playing up. If so, you could check the various ISP settings such as MTU (normally around the 1500 mark).

    Regards,

    PD
     
  3. On the cable connection i have a connection to the router but nothing past that. I can stay on the router's webpage without an issue but my network diagram doesn't go past the router and i cannot connect to the internet.
    I've tried a static address without any change, and also have tried DHCP and static without using IPv6.
    Logs weren't enabled (Just changed that) but i don't think the issue is with the ISP on this one.

    Cheers for the info,
    SparkySteve
     
  4. I've got a WRT-54GS, dumped the issue firmware a long time ago and have never looked back. I started with DD-WRT (Link) and am currently using something called Tomato(Link).

    Just make sure to read the small print, there are various versions of the hardware out there - will be on the bottom on the label (eg WRT54GS V.4) - and that may affect what you can do.

    Hope that helps
     
  5. SparkySteve

    Try doing a couple of command line things:

    type PATHPING -4 -T -w 60 mod.uk

    that should go off, try to find the mod.uk server at Rackspace, compute some network statistics and give you some bumph back. It just proves that your PC is configured to send and receive low-level traffic to a website without using a browser, as well as translate the internet name (mod.uk) to an IP address, which means that naming services are working ok too.
     
  6. It's unable to resolve it.

    I'll be trying the third-party firmware tomorrow.
    Here's a pic of the diagram Vista is giving me with the wired connection:
     

    Attached Files:

  7. That's wierd, can you try:

    NSLOOKUP mod.uk

    You should get something back along the lines of:

    Server: my.routername
    Address: 192.168.1.1

    Non-authoritative answer:
    Name: mod.uk
    Address: 83.138.180.46


    Which says DNS is working (the naming service thingy)
     
  8. You could also try:

    PATHPING 83.138.180.46

    That'll try to reach the MOD server without using DNS and work out whether IP traffic is flowing. I suspect not.