Help!! USB 2.0 WD Portable Hard-Drive not recognised by PC

Discussion in 'Gaming and Software' started by ArseyMO, Jan 24, 2008.

Welcome to the Army Rumour Service, ARRSE

The UK's largest and busiest UNofficial military website.

The heart of the site is the forum area, including:

  1. I've been using a Western Digital USB 2.0 Portable Hard-Drive for a couple of months with no drama.

    Yesterday the WD icon disappeared from my PC at work and when I tried to plug it into my Laptop later it wasn't recognised at all.

    I've tried the WD website which has been no help but do have a question in to their support guys awaiting an answer.

    Can someone tell me how to get my laptop to recognise the drive on the USB port. The drive does spool up and the power light is on so something is happening. However the windows yellow caution icon does not appear in the device manager.

    Txs
     
  2. I had the same problem when I bought a portable hard disk that had a integral card reader - my pc effectively ran out of drive letters! This _might_ be your problem.

    When the drive is attached go to Disk Management (Admin Tools > Computer Management). If the external drive is there, you can check that it has been allocated a drive letter. If not, you can then re-allocate a drive letter.
     
  3. Biped

    Biped LE Book Reviewer

    In many cases it's an intermittent problem with USB drives. Whenever I move drives around from one computer to another, it's 50/50 chance that it won't be picked up (rather than recognised) by the host computer.

    Suggest you try different USB ports, try plugging it into the PC first, THEN the HD, then turn it on, or turn it on, THEN plug the USB cable into the PC.

    Various combinations of stupidity to try until one of them will actually work.

    The problem is not that the computer does not recognise the drive - the problem is that the internal USB hub in the computer does not inform the OS that a new device has been plugged in. Thus, various combinations of plug-in jiggery-pokery will eventually 'notify' the OS.
     
  4. Have you tried leaving it connected and rebooting? Solved the same sort of glitch on one of my PCs
     
  5. Go to device manager uninstall all usb universal host controllers reboot allow windows to install drivers, Its a common fault with usb not being recognized or try going to mother board web page and look for updated drivers (not windows drivers)

    Its worth a try, sure as hell you will plug it in and your pc will pick it up right away.

    last of all is check for lost dll go to RUN type in sfc /scannow (cut and paste sfc /scannow) as there is a space between sfc /


    Windows XP has the ability to protect itself from system instability caused by the overwriting important system files. This is a problem with Windows 95 and Windows 98. With the introduction of Windows Millennium Edition, Microsoft made a strong effort to stop this from happening. Now, in Windows XP, there is a much better protection of these important files. This system is called Windows File Protection

    Windows File Protection is always enabled and allows Windows digitally signed files to replace existing files safely. If you introduce a file replacement in any other way, Windows File protection will overwrite your file!

    An important part of Windows File Protection is the command line utility: System File Checker (sfc.exe) This is a great tool for troubleshooting Windows XP problems.

    USING SFC /SCANNOW

    The main reason for using this utility is when you suspect there may be a problem with a Windows XP system file. Perhaps you get a dialog box appear informing you of a problem with a .dll file, or your program will just not load! It is therefore worth checking to see if there are any corrupt system files using scannow sfc.

    To do this simply go to the Run box on the Start Menu and type in: sfc /scannow

    This command will immediately initiate the Windows File Protection service to scan all protected files and make sure of their correctness, replacing any files that it finds with a problem.

    A bos should appear to give an indication of how long the process is taking.

    If all goes as it should, any corrupt, missing or incorrect files would be replaced by this process. However, as with most actions in this world, things can go wrong and the following should help!

    The most frequent complaint with scannow /sfc is that a dialog box appears asking you to insert your Windows XP CD-ROM to continue.

    Why does this happen?

    There are several settings in your computer's registry that are checked when you run scannow /sfc.

    As stated before, the Windows File Protection constantly monitors for any changes to the main system files. These are usually stored in:C:WINDOWSSystem32Dllcache (C: in most cases is the root drive)

    The dllcache folder is extremely important so Windows XP hides it from you! To view it go to:

    My Computer -> Tools -> Folder Options -> View -> "uncheck" Hide protected operating system files.
    There is normally no need for the original XP CD to be inserted as your computer has a copy it can get hold of in this cache.

    But, if the Dllcache folder, or part of it, has become corrupted for some reason then you will be prompted for the XP CD - so your computer can get a clean copy!

    However, not ALL installations of Windows XP have ALL the system files cached into this folder! You may only have around 25-50MB of files in this folder under Windows XP depending on the settings in the registry.

    HOW TO WORK AROUND THIS

    As well as having a cache of all the system files on your PC, you should have the I386 folder from the XP CD installed on your hard drive. After doing this, it is quite simple to modify the registry to tell it the source path for these files.

    This prevents 99% of requests for the the XP CD with Windows File Protection and the I386 folder also contains many other files that are sometimes needed by the operating system and this stops those requests for the XP CD,as well.

    HOW TO PUT I386 ON YOUR ROOT DRIVE:

    Step 1

    You will need to get your XP CD and locate the folder called: I386

    This is a major folder and should be one of the first you see, now copy this onto your hard drive into the system root. For most of you that is going to be C: so you should end up with a folder that looks like: C:I386

    Step 2

    Your computer needs to know that you now have the necessary files on your PC. This is done by editing the registry. Here's how: (type regedit in the Run box on the start menu)

    By navigating to:HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionSetup

    You will see various entries here on the right hand side.

    The one we want is called: SourcePath

    It probably has an entry pointing to your CD-ROM drive,(usually D:) and that is why it is asking for the XP CD. All we need to do is change it to: C: Now, double click the SourcePatch setting and a new box will pop up allowing you to make the change to the drive letter of your root drive, probably C:

    Now restart your computer and try sfc /scannow again!
     
  6. Simple things first. :)

    Check the power supply. With some USB devices the power/operation light will come on when it is connected to USB port even if you have no external power source but not enough power to run it properly.

    Most HDs have either a second usb cable for power or a seperate PSU either of these could be phucked.

    If it didn't need a seperate power supply before this don't mean it doesn't need one now, age slows everything down.
     
  7. Ha Ha........... You daft drop-short......
     
  8. [/quote]Ha Ha........... You daft drop-short......[/quote]

    Are there you are, I notice you failed to offer a helpful solution, but I've come to expect that.

    Txs everyone for the help, I'm trying them all as we speak, but no joy so far. I believe that the "driver" sits on the portable drive and self starts when it is plugged in. I think it was corrupted yesterday when the MOD kicked all the USB ports out in response to the missing laptop. I've had the ports restored but the problem remains.

    If the problem was a registry or port issue on my laptop then plugging it into another PC would make it work, it doesn't, therefore I'm assuming it's a driver issue.

    Santa, PS, where was my Xmas Card and did you have a "hot" New Year!
     
  9. How old is the drive? most Plug and Play portable HD do not rely on Drivers per se.

    Not advocating it yet, but out of intested is it a sealed unit or does it look like the internals are accesible? The reason I ask this is a lot of Portable Hard disks are just normal Hard Disks inside a Caddy. If this is the case, you can (as a last resort) remove the Hard disk. There are a few companies out there that will supply you with cables to attach a bare hard drive via USB (I have one myself from Maplins) This will rule out the possible problem of your Caddy being at fault.
    As a PS. those cables are ideal for people with old Hard disks lieing around from old PC's to use as Backup devices.
     
  10. New(ish) purchased last November.
     
  11. undo the caddy and check the ribbon cable is seated properly I had the same problem with my portable hd with the same symptoms
     
  12. Thought I would let you know where I'm at now, and ask for a little more advice.

    Worked my way through everything, so no joy. Can only assume that even though the drive appears to power up the heads have failed. I asked some advice from a friend last night and he suggested getting a USB HD Caddy from Maplins. I've looked on the internet and they cost around £20. Remove my drive from it's caddy and put it in the new one.

    So far I've got to the stage where I could do this, however I need to get to the disk itself. Before I do that I wondered has anyone else done this and is it straightforward?
     
  13. msr

    msr LE

    Yes and yes.

    Are both your computers work computers? It may well be that in the light of recent data losses someone has finally got round to disabling the USB ports.

    msr
     
  14. Must admit that was my first thought, but G6 at work have "assured" me that this is not the case.