grub error 21

Discussion in 'Gaming and Software' started by The_Rattler, Jun 7, 2008.

Welcome to the Army Rumour Service, ARRSE

The UK's largest and busiest UNofficial military website.

The heart of the site is the forum area, including:

  1. Anyone a Linux Guru out there.

    can tell me the best way to resolve this sort of issue and error (grub error 21


    the Rattler
  2. have you had a look here, It's full of answers
  3. If its not fixed by this evening i've got a mate from portugal who is using Linux and can help. Post back later today.
  4. yes thanks I did, I think really i should have expanded the question really

    basically i have purchased through a third party a (cisco call manager) CCM 6.1 (with a package of bolts ons) or CUCM. the guy who i have bought it off said he would sort it out but has ran into problems.

    he is unsure what the cause is as it could be one of many issues

    1. the OS (he's running Linux 5 and trying 6)
    2. the raid structure (I understand you can have a fake raid?) However the structure could be causing some internal format/logical issue
    3. He has also added an IP PBX (may be in conflict with current set up)
    4. The Raid structure may need more than one drive (0) currently may also need (1)
    5. The guy who's building it for me is very much like I am currently (well apart from been in the dark) windows server orientated and the key thing i am used to windows servers so my knowledge with Linux is limited/Nill

    CCM 6.1 is new to me (i am v 4-5 only) so really its the Linux thats the issue (so in addition it looks like i need a course anyway in Linux) but anything you may have or pointers is much appreciated.

    many thanks in advance

    The Rattler

    PS just received this in an email from him, would this make sense

    The more I think about it, this is a GRUB problem with our "LSI Integrated Ultra-100" raid controller (which is probably a version of "fakeraid".

    New Buzz word Fakeraid
  5. Good CO

    Good CO LE Admin

    I *may* have had this issue trying to use Linux on a dual boot system on an old PII. Grub was not compatible with the SCSI controller (this was well hidden in the Grub docs). A possible cure (although not the one we used) was to use LILO instead. Easy enough to try so could be worth a go?
  6. Thanks GCO, will chat with the Spam company and see if we can try this as an alternate solution
  7. Ok things have changed a bit, the equipment is now been shipped to me still not working properly.

    here we go, the server in question is possibly a MCS7825 or better model

    the linux been used is Ubuntu, however looking through the Linux threads this seems to be good for some systems and platforms and not others. the Fix also looks a little convoluted and i am starting my Linux induction course errr "NOW".

    So i have a couple of options but want to get any opinions that you may have of the following for Linux






    Fedora Core (this appears to be the better, or most stable)


    If anyone has any advice or experience on the above this would be most appreciated I will be trying everything out any from what has been advised

    cheers and beers
    the rattler :D
  8. Not a Linux guru, though I advertise it in my sig.

    Ubunto is a desktop OS and although it may be used on a server, probably not the best option?

    From the little I know, I believe Suse has rather good support, if you buy it.

    Fedora sounds a good option also.
  9. Cheers Jinxy will keep that in mind
  10. msr

    msr LE

    Ship it back and tell them to get a grip?

  11. well after many weeks of tinkering and playing around, I have my system working (have tried Ubuntu, Fedora and Redhat) this Grub 21 problem was not really a problem as such, the idiot who supplied me with the server gave me two hard drives that were BLER'd to say the least, now that i have configure the RAID properly and not wishy washy limp wristed "for a desk top PC" but as a server, all problems are gone.

    So the key thing from all this, if you are using Linux type programs and need to use RAID configurations, check all the hardware and Jumper settings as well as the system your using.

    thanks for those that have replied with advice (it all helped find the problem)