COD 4 problems.

Discussion in 'Gaming and Software' started by Biggles4221, Nov 9, 2007.

Welcome to the Army Rumour Service, ARRSE

The UK's largest and busiest UNofficial military website.

The heart of the site is the forum area, including:

  1. Hello all

    I have a very strange problem! I've just installed the game but when l click on start Single player icon on desktop, theres a brief pause and then l get a message saying " Please insert the correct DVD-ROM, select OK and restart application". However when l click on the multiplayer icon it loads up and l can play Online.
    I've tried to re install it, l've tried blowing on the cd and l've tried a rain dance but alas no joy. Any of you lot had the same problem? Any ARRSEs out there with any idea how to get around this? Thanks for your help chaps!

    My system is
    AMD 6200
    8800 GTX
    3 gig of RAM
    Windows XP
  2. The only obvious thing I can think of is that those symptoms are exactly what happens if you try to start the game without the DVD in the drive - multiplayer will start ok, but single player will ask for the DVD.

    Best thing is to uninstall it, and use some sort of cleanup tool to remove all the files left behind, in case one contains a corrupted key.

    Or your copy of CoD4 could be fake....
  3. No the copys legal ,ate. I've tried the unistall lark but still no joy!
  4. From their support site:
    Hold down the left shift key when inserting the game disc if this problem is occuring on launch.

    Make sure you have 32 bit drivers for your CD-ROM drive.

    Set the CD-ROM cache size to zero.

    Change the DMA setting on the CD-ROM drive.

    Make sure the drive letters for the CD-ROM is set correctly.

    Make sure that the location for CD music to play is set correctly.

    Make sure your system can successfully play Audio CD's.

    Turn off Auto Insert Notification.

    If you have the CD burning software Alcohol 120% installed you need to turn off all of the emulation options.
    1) Go to File > Options.
    2) Click on Emulation in the menu to the left.
    3) Uncheck all options in the window to the right.

    If you have CloneCD you need to turn off the Hide CDR media setting. This setting is accessable from the task tray icon for clone CD. Right-click on the icon and uncheck Hide CDR media.

    If you have an Nforce based motherboard go to and get the latest Nforce drivers for your motherboard chipset.
  5. Or back up your old .EXE and use a no cd crack.
  6. Your going to have to forgive me here mate. I'm a biff how dod you go about that then?
  7. Il send you a PM.
  8. i had the same problem with one of my drives, a SATA (optiarc 7170s)drive. but it plays in both my NEC drives which are both IDE.
  9. I have a PC, but today I bought an Xbox360 with this... I'm glad I'm not having the driver, etc nightmare for once, and can just plug & play!