Can connect to my Router but not to tinternet

Discussion in 'Gaming and Software' started by Sparky71, Dec 15, 2008.

Welcome to the Army Rumour Service, ARRSE

The UK's largest and busiest UNofficial military website.

The heart of the site is the forum area, including:

  1. A couple of years ago, my missus, bless her cotton socks, went out and bought an Evesham 'ebox' media centre PC. Now if we can skip the fact that the company only sold over priced boxes of components that shouldn't go together, and hence the reason that they went bust, I'm struggling to get the blasted piece of crud to connect to t'internet.

    I'm using a Belkin Wireless ADSL modem, model F5D7632-4, that has the latest firmware update installed. The PC I'm trying to connect with is using a Belkin USB wireless adaptor, F5D7050 - that came with the Router, so I'm not doubting it's compatability.

    My laptop and PDA will both happily talk to the Router and then out onto the internet, but the bl**dy PC will only get as far as the Router, it won't go any further.

    I've checked every possible setting I can find/think of, and as far as I can tell the config of the laptop and the PC match, but I have no idea why it still won't behave its twatting self.

    Any ideas welcomed.

    Cheers,

    Sparky
     
  2. Have you tried using an RJ45 cable to see if it works that way?

    Also, have you tried turning the encyption off and seeing if it works with the WEP etc off?

    It may help diagnose the fault.
     
  3. A friend of mine had a similar problem. They had the same laptop as myself, and could only connect to my wireless router, but not load any internet pages. MSN worked fine though. When he had it looked somehow all of his internet settings had changed. Something to do with the port numbers, or allocations! I know its not the best help, but I can ask him to find out more for you! :)
     
  4. What firewalls have you got installed the gf's dad had this problem he also had Norton :roll:
    One uninstall later and he was up and running
     
  5. Sympathetic_Reaction

    Sympathetic_Reaction LE Book Reviewer

    I've had something similar and a mate suggested it was the IPconfig settings.

    I did the following in the cmd window.

    ipconfig /release
    ipconfig /renew

    and it seemed to work again. I have to repeat this occassionally.

    not saying this is your problem, but it may be, it shouldn't hurt to try it.

    S_R
     
  6. Lads & Lasses,

    Many thanks for your swift replies. Have tried all of them but to no avail. The only thing I'm still to try is the direct connection to the router from the PC but my RJ45 cables have all gone AWOL.

    Am off to rummage around and see what I find.

    Many thanks,

    Sparky71
     
  7. Open up an internet explorer page and type in 192.168.2.1 then press go (this is the address of your router) this will bring up loads of settings for the router, make sure the wireless side of the router is on etc and check all the other settings, sometimes they have an auto config button or something like that.

    hope this helps
     
  8. RJ45 cable located, Router dragged half way round the house on various extension leads, plugged network cable into back of router and troublesome box of tricks, yet nada, exactly the same problem, the PC can see the router (and the config/settings screens) but can't see the internet, yet this laptop that I'm sat at right now can.

    Bl**dy computers. As unfathomable as burds.
     
  9. Possible cause.

    Has the PC had a IP address that is compatible with the router statically added? 192.168.x.x ?

    The PC will see the router etc but thats your lot.

    Check Network connections on the PC and set IP address to DHCP.

    Reboot or Run/cmd ipconfig /renew

    Only one I can think of off hand
     
  10. Just humour me "don't know how techy you are":

    Type Ipconfig then hit return.

    You should get the following:

    IP ADDRESS.......: 192.168.??.??
    SUBNET MASK.....: 255.255.255.0
    DEFAULT GATEWAY....:192.168.??.1

    if you get nothing like this then there is a problem with the IP settings on your PC to the router. (check that DHCP is enabled, the network card is enabled. try statically addressing the pc within the scope of the routers dhcp table)

    Then try this.

    Ping the default gasteway address ie

    ping 192.168.2.1

    if you get a reply try pinging an address ie

    ping www.google.co.uk

    if you get a positive reply then it is your browser that is the problem.

    Suggested route is reinstall the PC drastic but may work.
     
  11. I did as you suggested and got back the IP Address, Subnet Mask and Default Gateway as you stated.

    I then tried pinging the default gateway address and all I got back was "Ping request could not find host www.google.co.uk. Please check the name and try again". Tried the same on the laptop and it responded just fine.

    So it looks like it's not the browser that's the problem, just some other techno mumbo jumbo that you'd need a brain the size of planet to understand, and [thankfully] I'm just not *that* geeky.

    Steven, I did have a look but the IP address on the machine is set to DHCP.

    Cheers anyway Overpaid. I think I'm just going to vent my frustrations on the piece of shite with a hammer.

    Sparky71
     
  12. As a matter of interest, Have you tried to connect to the internet on your desktop while the laptop is turned off?
     
  13. Yep, still no joy. :(
     
  14. Can your desktop and laptop see each other on the network?